DoF quality

Support ForumCategory: IssuesDoF quality
uogi asked 4 years ago

Hi, 
is DoF with 3d models working as intended? I attached a screenshot that’s showing haloish blur and some
aliasing/black artefacts. Quality is extreme with shading and dof on. I have the latest version on AE 2017.
 

8 Answers
admin Staff answered 4 years ago

Hi, these black artefacts are the result of the2.5D transparent circle particles and the 3D cubes sharing an edge, the DOF is a post process, and as such you would get artefacts in some cases, a ‘True’ DOF for 3D and transparent particles, would slow the renders dramatically. While we will make this better going forward, you can output the Depth channel, and apply another post process DOF such as AE camera lens blur. 

Max answered 4 years ago

Hi! It’s very similar to some DoF presets in Element3D, if you are similar to this (great) plugin.
They implemented a “multipass” blur option, which is really slower to render, but deals great with this trouble. Why not implement such an option in further version of Stardust?
 
BR,

Max answered 4 years ago

Hi! It’s very similar to some DoF presets in Element3D, if you are similar to this (great) plugin.
They implemented a “multipass” blur option, which is really slower to render, but deals great with this trouble. Why not implement such an option in further version of Stardust?
 
BR,

Max answered 4 years ago

Hi! It’s very similar to some DoF presets in Element3D, if you are similar to this (great) plugin.
They implemented a “multipass” blur option, which is really slower to render, but deals great with this trouble. Why not implement such an option in further version of Stardust?
 
BR,

admin Staff answered 4 years ago

Hi Max, going forward, it is on our to-do to have an option for a better (and slower) DOF as I wrote here before, for now, you can export a Z pass, and use the AE camera lens blur to get more control over the blur.
 

Nate VP answered 11 months ago

Any updates on this?  My model’s edges are extremely haloed / blurry.

Nate VP answered 11 months ago

If you’re not able to solve the issue completely, would you be able to at least add a checkbox in the Stardust Render Settings to turn off DOF for a given instance of Stardust?  I have particles and a model in my scene.  I definitely need DOF on the particles, but I can live without it on the model, or add a separate blur effect if I need to.  I’ve separated my model out onto it’s own Solid layer, but I can’t find any way to disable DOF for the model while keeping it for the particles.
Also, the depth pass doesn’t work at all for particles, it seems, if they aren’t 3D models.

Nick answered 7 months ago

Hi Nate, to get around this i\’d make a separate comp with your particles and camera in there.   Then link the camera controls to your main comps camera (that has DOF). That way you\’ll get around that issue.   Hope that helped.   Cheers   Nick 

Your Answer

11 + 0 =

Error: Please enter a valid email address

Error: Invalid email

Error: Please enter your first name

Error: Please enter your last name

Error: Please enter a username

Error: Please enter a password

Error: Please confirm your password

Error: Password and password confirmation do not match